Enter the query into the form above. You can look for specific version of a package by using @ symbol like this: gcc@10.
API method:
GET /api/packages?search=hello&page=1&limit=20
where search is your query, page is a page number and limit is a number of items on a single page. Pagination information (such as a number of pages and etc) is returned
in response headers.
If you'd like to join our channel search send a patch to ~whereiseveryone/toys@lists.sr.ht adding your channel as an entry in channels.scm.
This is a Python library for time series data mining. It provides tools for time series classification, clustering and forecasting.
This package provides high-performance algorithm implementations to build visibility graphs from time series data.
This package provides a library implementing the Mapper algorithm in Python. KeplerMapper can be used for visualization of high-dimensional data and 3D point cloud data. KeplerMapper can make use of Scikit-Learn API compatible cluster and scaling algorithms.
Tadasets provides various utilities for creating and loading data sets that are useful for Topological Data Analysis. Currently, we provide several synthetic data sets with particular topological features.
This package provides Python bindings for PHAT, a software library which contains methods for computing the persistence pairs of a filtered cell complex represented by an ordered boundary matrix with Z2 coefficients.
This library provides easy to use constructors for custom filtrations that are suitable for use with Phat. Phat currently provides a clean interface for persistence reduction algorithms for boundary matrices. This tool helps bridge the gap between data and boundary matrices. Currently, we support construction of Alpha, Rips, and Cech filtrations.
Scikit-TDA is a home for Topological Data Analysis Python libraries intended for non-topologists. This project aims to provide a curated library of TDA Python tools that are widely usable and easily approachable. It is structured so that each package can stand alone or be used as part of the scikit-tda bundle.
S3 plugin for DVC.
This package provides the SSH/SFTP plugin for DVC.
This package provides the data management subsystem for DVC.
Common library for sending telemetry.
This package provides a client to interact with DVC Studio.
Turn a Git repository into an Artifact or Model Registry.
DVC is a free, open-source tool for data management, ML pipeline automation, and experiment management. This helps data science and machine learning teams manage large datasets.
dvc-render is a library for rendering data stored in DVC plots format into different output formats, like Vega. It can also generate HTML and MarkDown reports containing multiple plots.
Pytest test utilities used by DVC.
This package provides the HTTP plugin for DVC.
This package provides the filesystem and object-db level abstractions used by DVC.
This package provides a SCM wrapper and fsspec filesystem for Git for use in DVC.
This package provides the Celery-based task queue used by DVC.
Xbae is a Motif-based widget set consisting of the XbaeMatrix, XbaeCaption, and XbaeInput widgets. The XbaeMatrix widget displays a grid of cells like a spreadsheet. The cell array is scrollable, editable, and configurable in appearance. Each cell usually displays text. Pixmaps can also be displayed but are not editable.
uacme is a lightweight client for the RFC8555 ACMEv2 protocol, written in plain C with minimal dependencies. The ACMEv2 protocol allows a Certificate Authority such as Let's Encrypt and an applicant to automate the process of verification and certificate issuance.
uacme calls an external hook program with the tokens required for domain authorization. The hook program can be an executable, shell script, perl script, python script, or any file that the operating system can execute.
uacme is ACME challenge agnostic. It provides the user or hook program with all tokens and information required to complete any challenge type but leaves the task of setting up and cleaning up the challenge environment to the user or hook.
uacme also includes ualpn, a lightweight proxying tls-alpn-01 challenge responder compliant with RFC8737 and RFC8738.
Anubis is a web AI firewall utility that uses a combination of heuristics and challenges to identify and block bots before they take your website down. Anubis is as lightweight as possible and is designed to help protect the small internet from the endless storm of requests that flood in from AI companies.