Enter the query into the form above. You can look for specific version of a package by using @ symbol like this: gcc@10.
API method:
GET /api/packages?search=hello&page=1&limit=20
where search is your query, page is a page number and limit is a number of items on a single page. Pagination information (such as a number of pages and etc) is returned
in response headers.
If you'd like to join our channel search send a patch to ~whereiseveryone/toys@lists.sr.ht adding your channel as an entry in channels.scm.
This NGINX module allows adding, setting, or clearing any output or input header specified.
This is an enhanced version of the standard headers module because it provides more utilities like resetting or clearing "builtin headers" like Content-Type, Content-Length, and Server.
It also allows you to specify an optional HTTP status code criteria using the -s option and an optional content type criteria using the -t option while modifying the output headers with the more_set_headers and more_clear_headers directives.
Tibanna runs portable pipelines (in CWL/WDL and Snakemake) on the AWS Cloud.
The URI module implements the URI class. Objects of this class represent "Uniform Resource Identifier references" as specified in RFC 2396 and updated by RFC 2732.
This module attempts to answer, as accurately as it can, one of the nastiest technical questions there is: am I on the internet?
A host of networking and security issues make this problem very difficult. There are firewalls, proxies (both well behaved and badly behaved). We might not have DNS. We might not have a network card at all!
JSON-C implements a reference counting object model that allows you to easily construct JSON objects in C, output them as JSON-formatted strings and parse JSON-formatted strings back into the C representation of JSON objects. It aims to conform to RFC 7159.
This module provides a protocol-independent way to use IPv4 and IPv6 sockets, intended as a replacement for IO::Socket::INET.
This plugin links the two pieces required for session management in web applications together: the state, and the store.
The Jetty Web Server provides an HTTP server and Servlet container capable of serving static and dynamic content either from a standalone or embedded instantiation. This package provides utility classes.
CivetWeb is a web server with optional CGI and SSL support. It can be embedded into C/C++ applications or used as a standalone web server.
Gumbo is an implementation of the HTML5 parsing algorithm implemented as a pure C99 library.
SuperHTML is an HTML validator, formatter, LSP, and templating language library. It provides the superhtml command that can validate and autoformat HTML files. The tool can be used either directly (for example by running it on save), or through a LSP client implementation.
RapidJSON is a fast JSON parser/generator for C++ with both SAX/DOM style API.
HTTP::Lite is a stand-alone lightweight HTTP/1.1 implementation for perl. It is intended for use in situations where it is desirable to install the minimal number of modules to achieve HTTP support. HTTP::Lite is ideal for CGI (or mod_perl) programs or for bundling for redistribution with larger packages where only HTTP GET and POST functionality are necessary. HTTP::Lite is compliant with the Host header, necessary for name based virtual hosting, and supports proxies. Additionally, HTTP::Lite supports a callback to allow processing of request data as it arrives.
This module (HTTP::CookieJar::LWP) implements a minimalist HTTP user agent cookie jar in conformance with RFC 6265.
The HTTP::Negotiate module provides a complete implementation of the HTTP content negotiation algorithm specified in draft-ietf-http-v11-spec-00.ps chapter 12. Content negotiation allows for the selection of a preferred content representation based upon attributes of the negotiable variants and the value of the various Accept* header fields in the request.
nghttp3 is an implementation of RFC 9114 HTTP/3 mapping over QUIC and RFC 9204 QPACK in C. It does not depend on any particular QUIC transport implementation.
It implements extensions specified in RFC 9218 and RFC 9220. It supports SETTINGS_H3_DATAGRAM from RFC 9297.
It does not support server push.
This is a toolset for developing and deploying serverless Python code in AWS Lambda. This is a fork of Nick Ficano's Python-lambda package. It is frozen for the needs of projects at the 4D Nucleome Data Coordination and Integration Center (4DN-DCIC).
WebSocket++ is a C++ library that can be used to implement WebSocket functionality. The goals of the project are to provide a WebSocket implementation that is simple, portable, flexible, lightweight, low level, and high performance.
Digest::MD5::File is a Perl extension for getting MD5 sums for files and urls.
This perl module provides a wrapper around URI templates as described in RFC 6570.
Ikiwiki is a wiki compiler, capable of generating a static set of web pages, but also incorporating dynamic features like a web based editor and commenting.
This is a very simple HTTP/1.1 client, designed for doing simple requests without the overhead of a large framework like LWP::UserAgent. It supports proxies and redirection. It also correctly resumes after EINTR.
An HTTP::Message object contains some headers and a content body.