Enter the query into the form above. You can look for specific version of a package by using @ symbol like this: gcc@10.
API method:
GET /api/packages?search=hello&page=1&limit=20
where search is your query, page is a page number and limit is a number of items on a single page. Pagination information (such as a number of pages and etc) is returned
in response headers.
If you'd like to join our channel search send a patch to ~whereiseveryone/toys@lists.sr.ht adding your channel as an entry in channels.scm.
LibSass is a SASS compiler library designed for portability and efficiency. To actually compile SASS stylesheets, you'll need to use another program that uses this library, sassc for example.
Cat avatar generator is a generator of cat pictures optimised to generate random avatars, or defined avatar from a "seed". This is a derivation by David Revoy from the original MonsterID by Andreas Gohr.
LWP::UserAgent::Cached is an LWP::UserAgent subclass with cache support. It returns responses from the local file system, if available, instead of making an HTTP request.
The LWP::Protocol::https module provides support for using https schemed URLs with LWP.
The Jetty Web Server provides an HTTP server and Servlet container capable of serving static and dynamic content either from a standalone or embedded instantiation. This package provides the JMX management.
HTTP::Tinyish is a wrapper module for LWP, HTTP::Tiny, curl and wget.
It provides an API compatible to HTTP::Tiny.
JSON-C implements a reference counting object model that allows you to easily construct JSON objects in C, output them as JSON-formatted strings and parse JSON-formatted strings back into the C representation of JSON objects. It aims to conform to RFC 7159.
This is an HTTP to Gemini proxy designed to provide service for a single domain, i.e. to make your Gemini site available over HTTP. It can proxy to any domain in order to facilitate linking to the rest of Geminispace, but it defaults to a specific domain.
This is a module for building structured data from CGI inputs, in a manner reminiscent of how PHP does.
Provides HTML::TokeParser::Simple, a simpler interface to HTML::TokeParser for parsing HTML.
The LWP::MediaTypes module provides functions for handling media (also known as MIME) types and encodings. The mapping from file extensions to media types is defined by the media.types file. If the ~/.media.types file exists it is used instead.
This Catalyst plugin enables you to create "access logs" from within a Catalyst application instead of requiring a webserver to do it for you. It will work even with Catalyst debug logging turned off.
The Net::HTTP class is a low-level HTTP client. An instance of the Net::HTTP class represents a connection to an HTTP server. The HTTP protocol is described in RFC 2616. The Net::HTTP class supports HTTP/1.0 and HTTP/1.1.
WABT (pronounced: wabbit) is a suite of tools for WebAssembly, including:
wat2wasmtranslates from WebAssembly text format to the WebAssembly binary formatwasm2watis the inverse; it translates from the binary format back to the text format (also known as a .wat)wasm-objdumpprints information about a wasm binary, similarly toobjdump.wasm-interpdecodes ands run a WebAssembly binary file using a stack-based interpreterwat-desugarparses .wat text form as supported by the spec interpreter (s-expressions, flat syntax, or mixed) and prints the canonical flat formatwasm2cconverts a WebAssembly binary file to a C source and header file.
These tools are intended for use in (or for development of) toolchains or other systems that want to manipulate WebAssembly files.
WWWOFFLE is a proxy web server that is especially good for intermittent internet links. It can cache HTTP, HTTPS, FTP, and finger protocols, and supports browsing and requesting pages while offline, indexing, modifying pages and incoming and outgoing headers, monitoring pages for changes, and much more.
nghttp3 is an implementation of RFC 9114 HTTP/3 mapping over QUIC and RFC 9204 QPACK in C. It does not depend on any particular QUIC transport implementation.
It implements extensions specified in RFC 9218 and RFC 9220. It supports SETTINGS_H3_DATAGRAM from RFC 9297.
It does not support server push.
Iter Vitae is a command-line utility that allows you to generate a Resume / CV, by reading a S-expression version of your CV details (in Scheme code).
With a MVC approach, it lets you separate the data from the presentation (how the document looks).
This tool creates a web-site version of your CV (using SXML and Olive CSS), and is designed for long-term use, so you can update and evolve your CV over the years. The program supports multilingual content and is fully extensible.
This perl module provides a wrapper around URI templates as described in RFC 6570.
Test::WWW::Mechanize is a subclass of the Perl module WWW::Mechanize that incorporates features for web application testing.
The Guix Data Service stores data about GNU Guix, and provides this through a web interface. It supports listening to the guix-commits mailing list to find out about new revisions, then loads the data from these in to a PostgreSQL database.
LibDOM is an implementation of the W3C DOM, written in C. It is developed as part of the NetSurf project.
The Jetty Web Server provides an HTTP server and Servlet container capable of serving static and dynamic content either from a standalone or embedded instantiation. This package provides utility classes.
Signpost is the easy and intuitive solution for signing HTTP messages on the Java platform in conformance with the OAuth Core 1.0a standard. Signpost follows a modular and flexible design, allowing you to combine it with different HTTP messaging layers.
The HTTP::Date module provides functions that deal with date formats used by the HTTP protocol (and then some more).