_            _    _        _         _
      /\ \         /\ \ /\ \     /\_\      / /\
      \_\ \       /  \ \\ \ \   / / /     / /  \
      /\__ \     / /\ \ \\ \ \_/ / /     / / /\ \__
     / /_ \ \   / / /\ \ \\ \___/ /     / / /\ \___\
    / / /\ \ \ / / /  \ \_\\ \ \_/      \ \ \ \/___/
   / / /  \/_// / /   / / / \ \ \        \ \ \
  / / /      / / /   / / /   \ \ \   _    \ \ \
 / / /      / / /___/ / /     \ \ \ /_/\__/ / /
/_/ /      / / /____\/ /       \ \_\\ \/___/ /
\_\/       \/_________/         \/_/ \_____\/
go-github-com-tj-go-buffer 1.2.0
Channel: guix
Location: gnu/packages/golang-xyz.scm (gnu packages golang-xyz)
Home page: https://github.com/tj/go-buffer
Licenses: Expat
Build system: go
Synopsis: Generic buffer for batching entries, such as log events
Description:

Package buffer provides a generic buffer or batching mechanism for flushing entries at a given size or interval, useful for cases such as batching log events.

go-github-com-lann-builder 0.0.0-20180802200727-47ae307949d0
Propagated dependencies: go-github-com-lann-ps@0.0.0-20150810152359-62de8c46ede0
Channel: guix
Location: gnu/packages/golang-xyz.scm (gnu packages golang-xyz)
Home page: https://github.com/lann/builder
Licenses: Expat
Build system: go
Synopsis: Fluent immutable builders for Golang
Description:

Package builder provides a method for writing fluent immutable DSL builders. It uses immutable persistent data structures so that each step in the method chain can be reused.

go-github-com-vito-midterm 0.1.4
Propagated dependencies: go-github-com-charmbracelet-bubbletea@1.3.10 go-github-com-creack-pty@1.1.24 go-github-com-muesli-termenv@0.16.0 go-github-com-sebdah-goldie-v2@2.5.5 go-golang-org-x-term@0.44.0
Channel: guix
Location: gnu/packages/golang-xyz.scm (gnu packages golang-xyz)
Home page: https://github.com/vito/midterm
Licenses: Expat
Build system: go
Synopsis: In-memory terminal emulator
Description:

This package implements an in-memory terminal emulator, designed to be used as a component within a larger application for displaying logs, running interactive shells, or rendering terminal output.

go-github-com-zmap-zcrypto 0.0.0-0.0452b53
Propagated dependencies: go-github-com-mreiferson-go-httpclient@0.0.0-20201222173833-5e475fde3a4d go-github-com-op-go-logging@1 go-github-com-sirupsen-logrus@1.9.3 go-github-com-weppos-publicsuffix-go@0.50.2 go-github-com-zmap-zcertificate@0.0.1 go-golang-org-x-crypto@0.53.0 go-golang-org-x-net@0.53.0
Channel: guix
Location: gnu/packages/golang-crypto.scm (gnu packages golang-crypto)
Home page: https://github.com/zmap/zcrypto
Licenses: ASL 2.0 Expat ISC
Build system: go
Synopsis: Liberal Go TLS + X.509 Library for Research
Description:

ZCrypto is a research and data collection cryptography library, designed to be used for measuring and analyzing cryptographic deployments on the Internet. It is largely centered around the WebPKI.

go-github-com-go-test-deep 1.1.1
Channel: guix
Location: gnu/packages/golang-check.scm (gnu packages golang-check)
Home page: https://github.com/go-test/deep
Licenses: Expat
Build system: go
Synopsis: Human-friendly deep variable equality in Go
Description:

The deep package provides the deep.Equal function which is like reflect.DeepEqual but returns a list of differences. This is helpful when comparing complex types like structures and maps.

go-github-com-twmb-murmur3 1.1.8
Channel: guix
Location: gnu/packages/golang-crypto.scm (gnu packages golang-crypto)
Home page: https://github.com/twmb/murmur3
Licenses: Modified BSD
Build system: go
Synopsis: Native MurmurHash3 Go implementation
Description:

Native Go implementation of Austin Appleby's third MurmurHash revision (aka MurmurHash3). Reference algorithm has been slightly hacked as to support the streaming mode required by Go's standard Hash interface.

go-github-com-peterh-liner 1.2.2
Propagated dependencies: go-golang-org-x-sys@0.46.0 go-github-com-mattn-go-runewidth@0.0.19
Channel: guix
Location: gnu/packages/golang-xyz.scm (gnu packages golang-xyz)
Home page: https://github.com/peterh/liner
Licenses: Expat
Build system: go
Synopsis: Command line editor Go library
Description:

The liner Go package implements a simple command line editor with history, inspired by linenoise. Xterm as well as WIN32 terminal codes are supported.

go-github-com-tinylib-msgp 1.6.4
Propagated dependencies: go-github-com-philhofer-fwd@1.2.0 go-golang-org-x-tools@0.46.0
Channel: guix
Location: gnu/packages/golang-xyz.scm (gnu packages golang-xyz)
Home page: http://msgpack.org/
Licenses: Expat
Build system: go
Synopsis: MessagePack Code Generator
Description:

This package provides a code generation tool for creating methods to serialize and de-serialize Go data structures to and from data interchange format - MessagePack.

go-github-com-nsqio-go-nsq 1.1.0
Propagated dependencies: go-github-com-golang-snappy@0.0.4
Channel: guix
Location: gnu/packages/golang-xyz.scm (gnu packages golang-xyz)
Home page: https://github.com/nsqio/go-nsq
Licenses: Expat
Build system: go
Synopsis: Consumer/producer library for NSQ
Description:

The nsq Go module provides a high-level Consumer and Producer types as well as low-level functions to communicate over the NSQ protocol https://nsq.io/.

go-github-com-hako-durafmt 0.0.0-20210608123155-5c1018a8b0d2
Channel: guix
Location: gnu/packages/golang-xyz.scm (gnu packages golang-xyz)
Home page: https://github.com/hako/durafmt
Licenses: Expat
Build system: go
Synopsis: Time duration formatting for Go
Description:

This package provides human-readable time duration formatting for Go. It converts raw time durations into a more readable format, such as 2 weeks 3 days 4 hours 5 minutes 6 seconds.

go-github-com-muesli-mango 0.2.0
Propagated dependencies: go-github-com-muesli-roff@0.1.0
Channel: guix
Location: gnu/packages/golang-xyz.scm (gnu packages golang-xyz)
Home page: https://github.com/muesli/mango
Licenses: Expat
Build system: go
Synopsis: Golang man-page generator
Description:

This package provides a man-page generator for the Go flag, pflag, cobra, coral, and kong packages. It extracts commands, flags, and arguments from the target program and enables it to self-document.

go-github-com-rasky-go-xdr 0.0.0-20170124162913-1a41d1a06c93
Propagated dependencies: go-github-com-davecgh-go-xdr@0.0.0-20161123171359-e6a2ba005892
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://github.com/rasky/go-xdr
Licenses: ISC
Build system: go
Synopsis: XDR standard in pure Go
Description:

This package implements the data representation portion of the External Data Representation (XDR) standard protocol as specified in RFC4506 (obsoletes RFC 1832 and RFC 1014) in Go.

go-github-com-go-logr-logr 1.4.3
Channel: guix
Location: gnu/packages/golang-xyz.scm (gnu packages golang-xyz)
Home page: https://github.com/go-logr/logr
Licenses: ASL 2.0
Build system: go
Synopsis: Minimal logging API for Go
Description:

Package logr defines a general-purpose logging API and abstract interfaces to back that API. Packages in the Go ecosystem can depend on it, while callers can implement logging with whatever backend is appropriate.

go-github-com-miekg-pkcs11 1.1.1
Channel: guix
Location: gnu/packages/golang-crypto.scm (gnu packages golang-crypto)
Home page: https://github.com/miekg/pkcs11
Licenses: Modified BSD
Build system: go
Synopsis: PKCS #11 wrapper for Golang
Description:

This package provides an implementation of the PKCS#11 API. It wraps the library closely, but uses Go idiom where it makes sense. It has been tested with SoftHSM.

go-github-com-jeffail-gabs 1.4.0
Channel: guix
Location: gnu/packages/golang-xyz.scm (gnu packages golang-xyz)
Home page: https://github.com/Jeffail/gabs
Licenses: Expat
Build system: go
Synopsis: Parse, create and edit unknown or dynamic JSON in Golang
Description:

This package is a small utility for dealing with dynamic or unknown JSON structures. It's pretty much just a helpful wrapper for navigating hierarchies of map[string]interface objects provided by the encoding/json package.

emacs-git-auto-commit-mode 4.7.0
Channel: guix
Location: gnu/packages/emacs-xyz.scm (gnu packages emacs-xyz)
Home page: https://github.com/ryuslash/git-auto-commit-mode
Licenses: GPL 3+
Build system: emacs
Synopsis: Emacs Minor mode to automatically commit and push
Description:

git-auto-commit-mode is an Emacs minor mode that tries to commit changes to a file after every save.

When gac-automatically-push-p is non-nil, it also tries to push to the current upstream.

go-github-com-go-ap-jsonld 0.0.0-20260607140920-737b40e0ca38
Channel: guix
Location: gnu/packages/golang-xyz.scm (gnu packages golang-xyz)
Home page: https://github.com/go-ap/jsonld
Licenses: Expat
Build system: go
Synopsis: JSON-ld for Go
Description:

Package jsonld implements encoding and decoding of JSON as defined in RFC 4627. The mapping between JSON and Go values is described in the documentation for the Marshal and Unmarshal functions.

go-github-com-ulikunitz-xz 0.5.12
Channel: guix
Location: gnu/packages/golang-compression.scm (gnu packages golang-compression)
Home page: https://github.com/ulikunitz/xz
Licenses: Modified BSD
Build system: go
Synopsis: Read and write xz compressed streams in Go
Description:

This package provides a support of reading and writing of xz compressed streams. It includes also a gxz command for compressing and decompressing data. The package is completely written in Go and doesn't have any dependency on any C code.

go-github-com-xtls-reality 0.0.0-20260322125925-9234c772ba8f
Propagated dependencies: go-github-com-cloudflare-circl@1.6.5 go-github-com-juju-ratelimit@1.0.2 go-github-com-pires-go-proxyproto@0.11.0 go-github-com-refraction-networking-utls@1.8.2 go-golang-org-x-crypto@0.53.0 go-golang-org-x-sys@0.46.0
Channel: guix
Location: gnu/packages/golang-crypto.scm (gnu packages golang-crypto)
Home page: https://github.com/xtls/reality
Licenses: Modified BSD MPL 2.0
Build system: go
Synopsis: Implementation of REALITY protocol
Description:

This package provides an implementation of REALITY protocol, which is intented to eliminate the detectable TLS fingerprint on the server side, while still maintain the secrecy. It achieves full real TLS that is undistingwishable with the specified SNI to the middleman.

go-git-sr-ht-rjarry-go-opt 1.4.0
Channel: guix
Location: gnu/packages/golang-xyz.scm (gnu packages golang-xyz)
Home page: https://git.sr.ht/~rjarry/go-opt
Licenses: Expat
Build system: go
Synopsis: Argument parsing and completion based on struct tags
Description:

go-opt is a library to parse command line arguments based on tag annotations on struct fields. It came as a spin-off from aerc to deal with its internal commands.

go-github-com-x448-float16 0.8.4
Channel: guix
Location: gnu/packages/golang-maths.scm (gnu packages golang-maths)
Home page: https://github.com/x448/float16
Licenses: Expat
Build system: go
Synopsis: Float16 (Binary16) in Golang
Description:

This package provides a IEEE 754 half-precision floating-point format (binary16) with IEEE 754 default rounding for conversions. IEEE 754-2008 refers to this 16-bit floating-point format as binary16.

go-github-com-pjbgf-sha1cd 0.3.0
Channel: guix
Location: gnu/packages/golang-crypto.scm (gnu packages golang-crypto)
Home page: https://github.com/pjbgf/sha1cd
Licenses: ASL 2.0
Build system: go
Synopsis: sha1cd
Description:

Package sha1cd implements collision detection based on the whitepaper Counter-cryptanalysis from Marc Stevens. The original ubc implementation was done by Marc Stevens and Dan Shumow, and can be found at: @urlhttps://github.com/cr-marcstevens/sha1collisiondetection,https://github.com/cr-marcstevens/sha1collisiondetection.

go-github-com-jkeiser-iter 0.0.0-20200628201005-c8aa0ae784d1
Channel: guix
Location: gnu/packages/golang-xyz.scm (gnu packages golang-xyz)
Home page: https://github.com/jkeiser/iter
Licenses: Expat
Build system: go
Synopsis: Golang library for @code{iteration}
Description:

This package is intended to support forward-only iteration in a variety of use cases while avoiding the normal errors and leaks that can happen with iterators in Go. It provides mechanisms for map/select filtering, background iteration through a goroutine, and error handling throughout.

go-github-com-pborman-uuid 1.2.1
Propagated dependencies: go-github-com-google-uuid@1.6.0
Channel: guix
Location: gnu/packages/golang-xyz.scm (gnu packages golang-xyz)
Home page: https://github.com/pborman/uuid
Licenses: Modified BSD
Build system: go
Synopsis: Generates and inspects UUIDs
Description:

The uuid package generates and inspects UUIDs based on RFC 4122 and DCE 1.1: Authentication and Security Services. This package now leverages the github.com/google/uuid package (which is based off an earlier version of this package).

Page: 1…2122232425…115
Total packages: 2748