_            _    _        _         _
      /\ \         /\ \ /\ \     /\_\      / /\
      \_\ \       /  \ \\ \ \   / / /     / /  \
      /\__ \     / /\ \ \\ \ \_/ / /     / / /\ \__
     / /_ \ \   / / /\ \ \\ \___/ /     / / /\ \___\
    / / /\ \ \ / / /  \ \_\\ \ \_/      \ \ \ \/___/
   / / /  \/_// / /   / / / \ \ \        \ \ \
  / / /      / / /   / / /   \ \ \   _    \ \ \
 / / /      / / /___/ / /     \ \ \ /_/\__/ / /
/_/ /      / / /____\/ /       \ \_\\ \/___/ /
\_\/       \/_________/         \/_/ \_____\/
go-github-com-mholt-acmez-v2 2.0.3
Propagated dependencies: go-golang-org-x-crypto@0.53.0 go-golang-org-x-net@0.53.0 go-go-uber-org-zap@1.27.0
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://github.com/mholt/acmez
Licenses: ASL 2.0
Build system: go
Synopsis: ACME (RFC 8555) client library for Go
Description:

ACMEz is a lightweight, fully-compliant RFC 8555 (ACME) implementation, that provides an API for getting certificates. ACMEz is suitable for large-scale enterprise deployments. It also supports common IETF-standardized ACME extensions.

This module has two primary packages:

  • acmez is a high-level wrapper for getting certificates. It implements the ACME order flow described in RFC 8555 including challenge solving using pluggable solvers.

  • acme is a low-level RFC 8555 implementation that provides the fundamental ACME operations, mainly useful if you have advanced or niche requirements.

Main features:

  • Go API that thoroughly documented with spec citations.

  • Structured error values (problems as defined in RFC 7807.)

  • Smart retries (resilient against network and server hiccups.)

  • Challenge plasticity (randomized challenges, and will retry others if one fails.)

  • Context cancellation (suitable for high-frequency config changes or reloads.)

  • Highly flexible and customizable.

  • External Account Binding (EAB) support.

  • Tested with numerous ACME CAs (more than just Let's Encrypt.)

  • Implements niche aspects of RFC 8555 (such as alt cert chains and account key rollover.)

  • Efficient solving of large SAN lists (e.g. for slow DNS record propagation.)

  • Utility functions for solving challenges: device attestation challenges (draft-acme-device-attest-02), RFC 8737 (tls-alpn-01 challenge), RFC 8823 (email-reply-00 challenge; S/MIME.)

  • ACME Renewal Information (ARI) support (draft-ietf-acme-ari-03.)

go-github-com-42wim-go-gitter 0.0.0
Propagated dependencies: go-github-com-mreiferson-go-httpclient@0.0.0-20201222173833-5e475fde3a4d go-github-com-mrexodia-wray@0.0.0-20160318003008-78a2c1f284ff
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://github.com/42wim/go-gitter
Licenses: ASL 2.0
Build system: go
Synopsis: Gitter API in Go
Description:

This package provides a Gitter API for Golang.

go-github-com-u-root-uio-rand 0.0.0-20230305220412-3e8cd9d6bf63
Channel: hui
Location: hui/packages/proxy.scm (hui packages proxy)
Home page: https://github.com/u-root/uio
Licenses: Modified BSD
Build system: go
Synopsis: uio
#<unspecified>
go-github-com-spencercw-go-xz 0.0.0-20181128201811-c82a2123b492
Channel: lauras-channel
Location: laura/packages/go-common.scm (laura packages go-common)
Home page: https://github.com/spencercw/go-xz
Licenses:
Build system: go
Synopsis:
#<unspecified>
go-github-com-xanzy-go-gitlab 0.114.0
Propagated dependencies: go-github-com-google-go-querystring@1.1.0 go-github-com-hashicorp-go-cleanhttp@0.5.2 go-github-com-hashicorp-go-retryablehttp@0.7.8 go-golang-org-x-oauth2@0.36.0 go-golang-org-x-time@0.14.0
Channel: guix
Location: gnu/packages/golang-vcs.scm (gnu packages golang-vcs)
Home page: https://github.com/xanzy/go-gitlab
Licenses: ASL 2.0
Build system: go
Synopsis: GitLab Go SDK
Description:

This package provides a GitLab API client enabling Go programs to interact with GitLab in a simple and uniform way.

go-github-com-hooklift-assert 0.1.0
Channel: guixrus
Location: guixrus/packages/common/go.scm (guixrus packages common go)
Home page: https://github.com/hooklift/assert
Licenses: MPL 2.0
Build system: go
Synopsis: Minimalist assertion library
Description:

Minimalist assertion library

go-github-com-git-lfs-pktline 0.0.0-1.ca444d5
Channel: guix
Location: gnu/packages/golang-vcs.scm (gnu packages golang-vcs)
Home page: https://github.com/git-lfs/pktline
Licenses: Expat
Build system: go
Synopsis: Git pkt-line Go toolkit
Description:

This package is a Go language toolkit for reading and writing files using the Git pkt-line format used in various Git operations.

go-github-com-armon-go-socks5 0.0.0-20160902184237-e75332964ef5
Dependencies: go-golang-org-x-net@0.53.0
Channel: guixrus
Location: guixrus/packages/common/go.scm (guixrus packages common go)
Home page: https://github.com/armon/go-socks5
Licenses: Expat
Build system: go
Synopsis: SOCKS5 server in Golang
Description:

SOCKS5 server in Golang

go-github-com-tenntenn-modver 1.0.1
Propagated dependencies: go-github-com-hashicorp-go-version@1.7.0
Channel: guix
Location: gnu/packages/golang-check.scm (gnu packages golang-check)
Home page: https://github.com/tenntenn/modver
Licenses: Expat
Build system: go
Synopsis: Utility for Go modules
Description:

This package provides utilities for Go modules.

go-github-com-mtibben-percent 0.2.1
Channel: guix
Location: gnu/packages/golang-xyz.scm (gnu packages golang-xyz)
Home page: https://github.com/mtibben/percent
Licenses: Expat
Build system: go
Synopsis: Package percent escapes strings using percent-encoding
Description:

Package percent escapes strings using percent-encoding.

go-github-com-posener-autogen 0.0.3
Propagated dependencies: go-github-com-posener-script@1.2.0
Channel: guix
Location: gnu/packages/golang-xyz.scm (gnu packages golang-xyz)
Home page: https://github.com/posener/autogen
Licenses: ASL 2.0
Build system: go
Synopsis: Generate files from templates
Description:

Package autogen automatically generates files from templates.

go-github-com-zitadel-logging 0.6.2
Propagated dependencies: go-github-com-sirupsen-logrus@1.9.3
Channel: guix
Location: gnu/packages/golang-xyz.scm (gnu packages golang-xyz)
Home page: https://github.com/zitadel/logging
Licenses: ASL 2.0
Build system: go
Synopsis: Logging extension for Golang
Description:

This package implements an alternative logging extension.

go-github-com-tulir-maulogger 2.3.2
Channel: guixrus
Location: guixrus/packages/common/go.scm (guixrus packages common go)
Home page: https://maunium.net/go/maulogger/
Licenses: MPL 2.0
Build system: go
Synopsis: Logger in Go
Description:

MauLogger is a logger for Go programs.

go-github-com-carlmjohnson-be 0.25.2
Channel: cast
Location: cast/packages/wrtag.scm (cast packages wrtag)
Home page: https://github.com/carlmjohnson/be
Licenses: Expat
Build system: go
Synopsis: Go test helper for minimalists
Description:

be is a minimalist test assertion helper library.

go-github-com-tenntenn-golden 0.5.5
Propagated dependencies: go-github-com-josharian-txtarfs@0.0.0-20240408113805-5dc76b8fe6bf go-golang-org-x-tools@0.46.0
Channel: guix
Location: gnu/packages/golang-check.scm (gnu packages golang-check)
Home page: https://github.com/tenntenn/golden
Licenses: Expat
Build system: go
Synopsis: Utilities for golden file tests
Description:

This package provides utilities for golden file tests.

go-github-com-google-gopacket 1.1.19
Propagated dependencies: go-github-com-vishvananda-netlink@1.3.1 go-golang-org-x-net@0.53.0 go-golang-org-x-sys@0.46.0
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://github.com/google/gopacket
Licenses: Modified BSD
Build system: go
Synopsis: Packet processing capabilities library
Description:

This package provides packet processing capabilities for Go.

go-github-com-soniakeys-quant 1.0.0
Channel: guix
Location: gnu/packages/golang-xyz.scm (gnu packages golang-xyz)
Home page: https://github.com/soniakeys/quant
Licenses: Expat
Build system: go
Synopsis: Interface for image color quantizers
Description:

Quant provides an interface for image color quantizers.

go-github-com-gedex-inflector 0.0.0-20170307190818-16278e9db813
Channel: guix
Location: gnu/packages/golang-xyz.scm (gnu packages golang-xyz)
Home page: https://github.com/gedex/inflector
Licenses: FreeBSD
Build system: go
Synopsis: Go library that pluralizes and singularizes English nouns
Description:

Go library that pluralizes and singularizes English nouns.

go-github-com-subosito-gotenv 1.6.0
Propagated dependencies: go-golang-org-x-text@0.38.0
Channel: guix
Location: gnu/packages/golang-xyz.scm (gnu packages golang-xyz)
Home page: https://github.com/subosito/gotenv
Licenses: Expat
Build system: go
Synopsis: Go library for loading environment variables from files
Description:

Go library for loading environment variables from files

go-github-com-ipfs-go-ipfs-pq 0.0.3
Channel: guix
Location: gnu/packages/ipfs.scm (gnu packages ipfs)
Home page: https://github.com/ipfs/go-ipfs-pq
Licenses: Expat
Build system: go
Synopsis: Priority queue used by go-ipfs
Description:

Package pq implements a priority queue.

emacs-gitlab-ci-mode-flycheck 20190323.1829
Propagated dependencies: emacs-flycheck@20260902.1403 emacs-gitlab-ci-mode@20191022.2017
Channel: emacs
Location: emacs/packages/melpa.scm (emacs packages melpa)
Home page: https://gitlab.com/joewreschnig/gitlab-ci-mode-flycheck/
Licenses:
Build system: melpa
Synopsis: Flycheck support for ‘gitlab-ci-mode’
Description:

Documentation at https://melpa.org/#/gitlab-ci-mode-flycheck

go-github-com-yagipy-maintidx 1.0.0
Propagated dependencies: go-golang-org-x-tools@0.46.0
Channel: guix
Location: gnu/packages/golang-check.scm (gnu packages golang-check)
Home page: https://github.com/yagipy/maintidx
Licenses: Expat
Build system: go
Synopsis: Measure maintainibility indices
Description:

This package measures the maintainability index of Go functions.

go-github-com-xtaci-lossyconn 0.0.0-20200209145036-adba10fffc37
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://github.com/xtaci/lossyconn
Licenses: Expat
Build system: go
Synopsis: Lossy connection simulator
Description:

Package lossyconn is a lossy connection simulator for Golang.

Page: 1…3738394041…115
Total packages: 2748