Carbon is a backend data caching and persistence daemon for Graphite. Carbon is responsible for receiving metrics over the network, caching them in memory for "hot queries" from the Graphite-Web application, and persisting them to disk using the Whisper time-series library.
Vector is a Python library for 2D and 3D spatial vectors, as well as 4D space-time vectors. It is especially intended for performing geometric calculations on arrays of vectors, rather than one vector at a time in a Python for loop.
Invoke is a Python task execution tool and library, drawing inspiration from various sources to arrive at a powerful and clean feature set. It is evolved from the Fabric project, but focuses on local and abstract concerns instead of servers and network commands.
Read one-dimensional barcodes and QR codes using the zbar library.
Features:
Pure python
Works with PIL / Pillow images, OpenCV / numpy ndarrays, and raw bytes
Decodes locations of barcodes
No dependencies, other than the zbar library itself
Django is a high-level Python Web framework that encourages rapid development and clean, pragmatic design. It provides many tools for building any Web site. Django focuses on automating as much as possible and adhering to the don't repeat yourself (DRY) principle.
Captum is a model interpretability and understanding library for PyTorch. Captum contains general purpose implementations of integrated gradients, saliency maps, smoothgrad, vargrad and others for PyTorch models. It has quick integration for models built with domain-specific libraries such as torchvision, torchtext, and others.
This package includes a variety of tools used to analyze persistence diagrams. It currently houses implementations of
Persistence images
Persistence landscapes
Bottleneck distance
Modified Gromov–Hausdorff distance
Sliced Wasserstein kernel
Heat kernel
Diagram plotting
PyYAML is a YAML parser and emitter for Python. PyYAML features a complete YAML 1.1 parser, Unicode support, pickle support, capable extension API, and sensible error messages. PyYAML supports standard YAML tags and provides Python-specific tags that represent an arbitrary Python object.
rJSmin is a javascript minifier written in Python. The minifier is based on the semantics of jsmin.c by Douglas Crockford. The module is a re-implementation aiming for speed, so it can be used at runtime (rather than during a preprocessing step).
Bandit is a tool designed to find common security issues in Python code. To do this Bandit processes each file, builds an AST from it, and runs appropriate plugins against the AST nodes. Once Bandit has finished scanning all the files it generates a report.
Pydbus provides a pythonic interface to the D-Bus message bus system. Pydbus can be used to access remote objects and also for object publication. It is based on PyGI, the Python GObject Introspection bindings, which is the recommended way to use GLib from Python.
Pydbus provides a pythonic interface to the D-Bus message bus system. Pydbus can be used to access remote objects and also for object publication. It is based on PyGI, the Python GObject Introspection bindings, which is the recommended way to use GLib from Python.
PyStoG is a Python package for converting between different total scattering functions used in crystalline and amorphous materials research. It handles reciprocal-space structure factors and real-space pair distribution functions, performing Fourier transforms between them and applying filters to remove spurious artifacts in the data.
diemPy is a computational tool designed to polarize genomic data for hybrid zone analysis. The package implements an expectation-maximization (EM) algorithm to determine the optimal polarization of genetic markers, enabling researchers to identify and analyze patterns of introgression and hybridization in genomic datasets.
Python module that implements DKIM (DomainKeys Identified Mail) email signing and verification (RFC6376). It also provides helper scripts for command line signing and verification. It supports DKIM signing/verifying of ed25519-sha256 signatures (RFC 8463). It also supports the RFC 8617 Authenticated Received Chain (ARC) protocol.
This library brings the Olson tz database into Python. It allows accurate and cross platform timezone calculations using Python 2.4 or higher. It also solves the issue of ambiguous times at the end of daylight saving time. Almost all of the Olson timezones are supported.
CVXOPT is a package for convex optimization based on the Python programming language. Its main purpose is to make the development of software for convex optimization applications straightforward by building on Python’s extensive standard library and on the strengths of Python as a high-level programming language.
Pandas is a Python package providing fast, flexible, and expressive data structures designed to make working with structured (tabular, multidimensional, potentially heterogeneous) and time series data both easy and intuitive. It aims to be the fundamental high-level building block for doing practical, real world data analysis in Python.
ACME is Automatic Certificate Management Environment, a protocol that allows clients and certificate authorities to automate verification and certificate issuance. The ACME protocol is used by the free Let's Encrypt Certificate Authority.
txacme is an implementation of the protocol for Twisted, the event-driven networking engine for Python.
This package provides Python bindings for the Libdiscid library. The main purpose is the calculation of Disc IDs for use with the MusicBrainz database. Additionally the disc Media Catalog Number (MCN) and track International Standard Recording Code (ISRC) can be extracted.
Python-pathos is a framework for heterogeneous computing. It provides a consistent high-level interface for configuring and launching parallel computations across heterogeneous resources. Python-pathos provides configurable launchers for parallel and distributed computing, where each launcher contains the syntactic logic to configure and launch jobs in an execution environment.
The purpose of this package is to produce a template or specification for a file-system interface, that specific implementations should follow, so that applications making use of them can rely on a common behavior and not have to worry about the specific internal implementation decisions with any given backend.
The loom file format is an efficient format for very large omics datasets, consisting of a main matrix, optional additional layers, a variable number of row and column annotations. Loom also supports sparse graphs. This library makes it easy to work with .loom files for single-cell RNA-seq data.
The libnl suite is a collection of libraries providing APIs to netlink protocol based Linux kernel interfaces. Netlink is an IPC mechanism primarily between the kernel and user space processes. It was designed to be a more flexible successor to ioctl to provide mainly networking related kernel configuration and monitoring interfaces.