Enter the query into the form above. You can look for specific version of a package by using @ symbol like this: gcc@10.
API method:
GET /api/packages?search=hello&page=1&limit=20
where search is your query, page is a page number and limit is a number of items on a single page. Pagination information (such as a number of pages and etc) is returned
in response headers.
If you'd like to join our channel search send a patch to ~whereiseveryone/toys@lists.sr.ht adding your channel as an entry in channels.scm.
This package provides Steve Harris's LADSPA plugins.
This package provides an encoder for the LDAC high-resolution Bluetooth audio streaming codec for streaming at up to 990 kbps at 24 bit/96 kHz.
Tenacity is a multi-track audio editor designed for recording, playing and editing digital audio. It features digital effects and spectrum analysis tools.
Pure Python bindings for Augeas.
Augeas is a library and command line tool for programmatically editing configuration files in a controlled manner. Augeas exposes a tree of all configuration settings and a simple local API for manipulating the tree. Augeas then modifies underlying configuration files according to the changes that have been made to the tree; it does as little modeling of configurations as possible, and focuses exclusivley on transforming the tree-oriented syntax of its public API to the myriad syntaxes of individual configuration files.
The OATH Toolkit provides various components for building OTP authentication systems:
oathtool, a command-line tool for generating & validating OTPs.liboath, a C library for OATH handling.pskctool, a command-line tool for manipulating secret key files in the PSKC format described in RFC6030.libpskc, a shared and static C library for PSKC handling.pam_oath, a PAM module for pluggable login authentication.
Supported technologies include the event-based HOTP algorithm (RFC4226), the time-based TOTP algorithm (RFC6238), and PSKC (RFC6030) to manage secret key data.
Pamtester is a tiny utility program to test the pluggable authentication modules (PAM) facility, specifically designed to help PAM module authors to intensively test their own modules.
This package provides a library to generate HOTPs as specified in RFC 4226 and TOTPs as specified in RFC 6238.
oauth2l (pronounced ``oauth tool'') is a simple command-line tool for working with Google OAuth 2.0 written in Go. Its primary use is to fetch and print OAuth 2.0 access tokens, which can be used with other command-line tools and scripts.
The Yubico PAM module provides an easy way to integrate the YubiKey into your existing user authentication infrastructure.
AutoGen is a program to ease the maintenance of programs that contain large amounts of repetitive text. It automates the construction of these sections of the code, simplifying the task of keeping the text in sync. It also includes an add-on package called AutoOpts, which is specialized for the maintenance and documentation of program options.
Autoconf offers the developer a robust set of M4 macros which expand into shell code to test the features of Unix-like systems and to adapt automatically their software package to these systems. The resulting shell scripts are self-contained and portable, freeing the user from needing to know anything about Autoconf or M4.
Automake the part of the GNU build system for producing standards-compliant Makefiles. Build requirements are entered in an intuitive format and then Automake works with Autoconf to produce a robust Makefile, simplifying the entire process for the developer.
The `config.guess' script tries to guess a canonical system triple, and `config.sub' validates and canonicalizes. These are used as part of configuration in nearly all GNU packages (and many others).
GNU Libtool helps in the creation and use of shared libraries, by presenting a single consistent, portable interface that hides the usual complexity of working with shared libraries across platforms.
Automake the part of the GNU build system for producing standards-compliant Makefiles. Build requirements are entered in an intuitive format and then Automake works with Autoconf to produce a robust Makefile, simplifying the entire process for the developer.
Autoconf offers the developer a robust set of M4 macros which expand into shell code to test the features of Unix-like systems and to adapt automatically their software package to these systems. The resulting shell scripts are self-contained and portable, freeing the user from needing to know anything about Autoconf or M4.
Autobuild is a package that processes build logs generated when building software. Autobuild is primarily focused on packages using Autoconf and Automake, but can be used with other build systems too. Autobuild generates an HTML summary file, containing links to each build log. The summary includes project name, version, build hostname, host type (cross compile aware), date of build, and indication of success or failure. The output is indexed in many ways to simplify browsing.
GNU pyconfigure provides template files for easily implementing standards-compliant configure scripts and Makefiles for Python-based packages. It is designed to work alongside existing Python setup scripts, making it easy to integrate into existing projects. Powerful and flexible Autoconf macros are available, allowing you to easily make adjustments to the installation procedure based on the capabilities of the target computer.
Autoconf offers the developer a robust set of M4 macros which expand into shell code to test the features of Unix-like systems and to adapt automatically their software package to these systems. The resulting shell scripts are self-contained and portable, freeing the user from needing to know anything about Autoconf or M4.
Autoconf offers the developer a robust set of M4 macros which expand into shell code to test the features of Unix-like systems and to adapt automatically their software package to these systems. The resulting shell scripts are self-contained and portable, freeing the user from needing to know anything about Autoconf or M4.
Autoconf Archive is a collection of over 450 new macros for Autoconf, greatly expanding the domain of its functionality. These macros have been contributed as free software by the community.
Autoconf offers the developer a robust set of M4 macros which expand into shell code to test the features of Unix-like systems and to adapt automatically their software package to these systems. The resulting shell scripts are self-contained and portable, freeing the user from needing to know anything about Autoconf or M4.
GNU Libtool helps in the creation and use of shared libraries, by presenting a single consistent, portable interface that hides the usual complexity of working with shared libraries across platforms.