_            _    _        _         _
      /\ \         /\ \ /\ \     /\_\      / /\
      \_\ \       /  \ \\ \ \   / / /     / /  \
      /\__ \     / /\ \ \\ \ \_/ / /     / / /\ \__
     / /_ \ \   / / /\ \ \\ \___/ /     / / /\ \___\
    / / /\ \ \ / / /  \ \_\\ \ \_/      \ \ \ \/___/
   / / /  \/_// / /   / / / \ \ \        \ \ \
  / / /      / / /   / / /   \ \ \   _    \ \ \
 / / /      / / /___/ / /     \ \ \ /_/\__/ / /
/_/ /      / / /____\/ /       \ \_\\ \/___/ /
\_\/       \/_________/         \/_/ \_____\/

Enter the query into the form above. You can look for specific version of a package by using @ symbol like this: gcc@10.

API method:

GET /api/packages?search=hello&page=1&limit=20

where search is your query, page is a page number and limit is a number of items on a single page. Pagination information (such as a number of pages and etc) is returned in response headers.

If you'd like to join our channel search send a patch to ~whereiseveryone/toys@lists.sr.ht adding your channel as an entry in channels.scm.


ecl-staple 2.0.0-1.0ee8e25
Dependencies: ecl-3bmd@0.0.0-4.e68b2d4 ecl-babel@0.5.0-3.627d6a6 ecl-cl-docutils@0.1.1-1.756b5ad ecl-cl-markless@1.1.0-1.a0e145c ecl-cl-ppcre@2.1.1 ecl-clip@0.7.0-1.7afa687 ecl-concrete-syntax-tree@0.3.0 ecl-definitions@1.0.0-2.8697960 ecl-documentation-utils@1.2.0-1.cd5b506 ecl-eclector@0.10.0-0.28d2944 ecl-language-codes@1.0.0-1.e7aa0e3 ecl-pathname-utils@1.1.0-5.c0aa51a
Channel: guix
Location: gnu/packages/lisp-xyz.scm (gnu packages lisp-xyz)
Home page: https://Shinmera.github.io/staple/
Licenses: Zlib
Build system: asdf/ecl
Synopsis: Generate documentation about Lisp projects through an HTML template
Description:

Staple is a documentation system. It provides you with a way to generate standalone documentation accumulated from various sources such as readmes, documentation files, and docstrings.

sbcl-data-format-validation 0.2.0-1.95d4476
Dependencies: sbcl-cl-ppcre@2.1.1
Channel: guix
Location: gnu/packages/lisp-xyz.scm (gnu packages lisp-xyz)
Home page: http://www.jarw.org.uk/lisp/cl-data-format-validation.html
Licenses: GPL 3
Build system: asdf/sbcl
Synopsis: Validation and conversion between user and internal data
Description:

data-format-validation is a library for Common Lisp providing a consistent regular interface for converting (and validating) external data (in the form of strings usually) into internal data types and for formatting internal data back into external presentable strings, all according to a conversion or type specification.

sbcl-cl-data-structures 1.4.1-3.d11e589
Dependencies: sbcl-alexandria@1.4-0.009b7e5 sbcl-bordeaux-threads@0.9.3 sbcl-cl-ppcre@2.1.1 sbcl-closer-mop@1.0.0-3.7b86f2a sbcl-documentation-utils-extensions@0.0.0-1.f67f8a0 sbcl-flexichain@1.5.1-2.9af644a sbcl-iterate@1.5.3 sbcl-lparallel@2.8.4-1.80fc295 sbcl-metabang-bind@0.8.0-2.0819642 sbcl-more-conditions@0.4.5-1.b4859fb sbcl-serapeum@0.0.0-13.71f35c9 sbcl-trivial-garbage@0.21-0.3474f64
Channel: guix
Location: gnu/packages/lisp-xyz.scm (gnu packages lisp-xyz)
Home page: https://sirherrbatka.github.io/cl-data-structures/main.html
Licenses: FreeBSD
Build system: asdf/sbcl
Synopsis: Data Structures and streaming algorithms for Common Lisp
Description:

CL-DATA-STRUCTURES is a Common Lisp library providing a portable collection of mutable and immutable data structures (dictionaries, sets, queues, sequences) and algorithms.

sbcl-hunchentoot 1.3.1
Dependencies: sbcl-chunga@1.1.9 sbcl-cl-base64@3.3.4-1.577683b sbcl-cl-fad@0.7.6-1.3f4d32d sbcl-cl-ppcre@2.1.1 sbcl-flexi-streams@1.0.20-1.4951d57 sbcl-cl+ssl@0.0.0-6.17d5cdd sbcl-md5@2.0.5 sbcl-rfc2388@0.0.0-1.591bcf7 sbcl-trivial-backtrace@1.1.0-2.7f90b4a sbcl-usocket@0.8.9
Channel: guix
Location: gnu/packages/lisp-xyz.scm (gnu packages lisp-xyz)
Home page: https://edicl.github.io/hunchentoot/
Licenses: FreeBSD
Build system: asdf/sbcl
Synopsis: Web server written in Common Lisp
Description:

Hunchentoot is a web server written in Common Lisp and at the same time a toolkit for building dynamic websites. As a stand-alone web server, Hunchentoot is capable of HTTP/1.1 chunking (both directions), persistent connections (keep-alive), and SSL.

ecl-cl-inflector 0.2-1.f1ab169
Dependencies: ecl-alexandria@1.4-0.009b7e5 ecl-cl-ppcre@2.1.1
Channel: guix
Location: gnu/packages/lisp-xyz.scm (gnu packages lisp-xyz)
Home page: https://github.com/AccelerationNet/cl-inflector
Licenses: Expat
Build system: asdf/ecl
Synopsis: Library to pluralize/singularize English and Portuguese words
Description:

This is a common lisp library to easily pluralize and singularize English and Portuguese words. This is a port of the ruby ActiveSupport Inflector module.

ecl-damn-fast-priority-queue 0.0.2-0.f4c0374
Dependencies: ecl-alexandria@1.4-0.009b7e5
Channel: guix
Location: gnu/packages/lisp-xyz.scm (gnu packages lisp-xyz)
Home page: https://github.com/phoe/damn-fast-priority-queue
Licenses: Expat
Build system: asdf/ecl
Synopsis: Fast priority queue
Description:

A heap-based priority queue whose first and foremost priority is speed.

sbcl-universal-tween-engine 1.0.0-0.a86d3c6
Dependencies: sbcl-alexandria@1.4-0.009b7e5
Channel: guix
Location: gnu/packages/lisp-xyz.scm (gnu packages lisp-xyz)
Home page: https://github.com/bohonghuang/cl-universal-tween-engine
Licenses: ASL 2.0
Build system: asdf/sbcl
Synopsis: Common Lisp port of Universal Tween Engine
Description:

Common Lisp port of Universal Tween Engine.

sbcl-simple-date-time 0.1.0-1.d6992af
Dependencies: sbcl-cl-ppcre@2.1.1
Channel: guix
Location: gnu/packages/lisp-xyz.scm (gnu packages lisp-xyz)
Home page: https://github.com/quek/simple-date-time
Licenses: Original BSD
Build system: asdf/sbcl
Synopsis: Date and time library for Common Lisp
Description:

This package is a simple date and time library.

cl-jpeg 2.8-1.ec55703
Channel: guix
Location: gnu/packages/lisp-xyz.scm (gnu packages lisp-xyz)
Home page: https://github.com/sharplispers/cl-jpeg
Licenses: Modified BSD
Build system: asdf/source
Synopsis: JPEG image library for Common Lisp
Description:

This is a baseline JPEG codec written in Common Lisp. It can be used for reading and writing JPEG image files.

ecl-path-parse 0.1-1.86183f3
Dependencies: ecl-split-sequence@2.0.1
Channel: guix
Location: gnu/packages/lisp-xyz.scm (gnu packages lisp-xyz)
Home page: https://github.com/eudoxia0/path-parse
Licenses: Expat
Build system: asdf/ecl
Synopsis: Parse the PATH environment variable in Common Lisp
Description:

This package provides a function to parse the PATH environment variable portably in Common Lisp.

ecl-ieee-floats 20170924-1.566b51a
Channel: guix
Location: gnu/packages/lisp-xyz.scm (gnu packages lisp-xyz)
Home page: https://github.com/marijnh/ieee-floats/
Licenses: Modified BSD
Build system: asdf/ecl
Synopsis: IEEE 754 binary representation for floats in Common Lisp
Description:

This is a Common Lisp library that converts floating point values to IEEE 754 binary representation.

ecl-fset 2.4.6
Dependencies: ecl-alexandria@1.4-0.009b7e5 ecl-iterate@1.5.3 ecl-jzon@1.1.4 ecl-misc-extensions@4.2.4 ecl-mt19937@1.1 ecl-named-readtables@0.9-5.aa6dab5
Channel: guix
Location: gnu/packages/lisp-xyz.scm (gnu packages lisp-xyz)
Home page: https://common-lisp.net/project/fset/Site/index.html
Licenses: FreeBSD
Build system: asdf/ecl
Synopsis: Functional set-theoretic collections library
Description:

FSet is a functional set-theoretic collections library for Common Lisp. Functional means that all update operations return a new collection rather than modifying an existing one in place. Set-theoretic means that collections may be nested arbitrarily with no additional programmer effort; for instance, sets may contain sets, maps may be keyed by sets, etc.

cl-jpeg-turbo 1.0-1.f79c646
Dependencies: libjpeg-turbo@2.1.4
Propagated dependencies: cl-cffi@0.24.1-2.32c90d4 cl-fiveam@1.4.2
Channel: guix
Location: gnu/packages/lisp-xyz.scm (gnu packages lisp-xyz)
Home page: https://github.com/shamazmazum/jpeg-turbo/
Licenses: FreeBSD
Build system: asdf/source
Synopsis: Common Lisp wrapper for libjpeg-turbo
Description:

This is a Common Lisp wrapper for libjpeg-turbo library which provides TurboJPEG API for compressing and decompressing JPEG images.

cl-generic-comparability 1.0.1-1.53fc284
Propagated dependencies: cl-alexandria@1.4-0.009b7e5 cl-fiveam@1.4.2
Channel: guix
Location: gnu/packages/lisp-xyz.scm (gnu packages lisp-xyz)
Home page: https://github.com/pnathan/generic-comparability
Licenses: LLGPL
Build system: asdf/source
Synopsis: Implementation of cdr-8
Description:

GENERIC-COMPARABILITY is an implementation of CDR-8 (Generic Equality and Comparison for Common Lisp). CDR-8 provides an interface for the EQUALS function, which is defined as a general equality predicate, as well as a set of ordering (COMPARE) functions for comparison. The semantics are described in the CDR-8 standard.

ecl-puri 1.5.7-2.4bbab89
Channel: guix
Location: gnu/packages/lisp-xyz.scm (gnu packages lisp-xyz)
Home page: http://puri.kpe.io/
Licenses: LLGPL
Build system: asdf/ecl
Synopsis: Portable URI Library
Description:

This is a portable Universal Resource Identifier library for Common Lisp programs. It parses URI according to the RFC 2396 specification.

ecl-stripe 0.0.0-0.b59631d
Dependencies: ecl-dexador@0.9.15-3.d7ac217 ecl-golden-utils@0.0.0-4.e43914a ecl-local-time@1.0.6-4.40169fe ecl-yason@0.8.4
Channel: guix
Location: gnu/packages/lisp-xyz.scm (gnu packages lisp-xyz)
Home page: https://github.com/atlas-engineer/stripe
Licenses: Expat
Build system: asdf/ecl
Synopsis: Stripe payment API client for Common Lisp
Description:

A client for the Stripe payment API.

cl-inquisitor 0.5-0.423fa9b
Propagated dependencies: cl-flexi-streams@1.0.20-1.4951d57 cl-alexandria@1.4-0.009b7e5 cl-anaphora@0.9.8 cl-prove@1.0.0-2.5d71f02 cl-babel@0.5.0-3.627d6a6
Channel: guix
Location: gnu/packages/lisp-xyz.scm (gnu packages lisp-xyz)
Home page: https://github.com/t-sin/inquisitor
Licenses: Expat
Build system: asdf/source
Synopsis: Encoding/end-of-line detection and external-format abstraction for Common Lisp
Description:

Inquisitor is a cross-implementation library providing encoding/end-of-line detection and external-format abstraction for Common Lisp.

sbcl-trivial-rfc-1123 0.0.0-0.9ef59c3
Dependencies: sbcl-cl-ppcre@2.1.1
Channel: guix
Location: gnu/packages/lisp-xyz.scm (gnu packages lisp-xyz)
Home page: https://github.com/stacksmith/trivial-rfc-1123
Licenses: Modified BSD
Build system: asdf/sbcl
Synopsis: Parse and print RFC-1123 timestamps
Description:

This package parses and prints dates in RFC-1123 format.

ecl-percent-encoding 0.1-1.c1224e2
Dependencies: ecl-anaphora@0.9.8 ecl-babel@0.5.0-3.627d6a6
Channel: guix
Location: gnu/packages/lisp-xyz.scm (gnu packages lisp-xyz)
Home page: https://github.com/llibra/percent-encoding
Licenses: Expat
Build system: asdf/ecl
Synopsis: RFC 3986 percent-encoding library
Description:

This is a Common Lisp library providing RFC 3986 percent-encoding.

cl-april 1.0.0-4.0001af6
Propagated dependencies: cl-alexandria@1.4-0.009b7e5 cl-array-operations@0.0.0-0.75cbc3b cl-ppcre@2.1.1 cl-unicode@0.1.6 cl-lparallel@2.8.4-1.80fc295 cl-maxpc@0.0.0-1.e5e58d0 cl-parse-number@1.8 cl-prove@1.0.0-2.5d71f02 cl-random-state@0.1.0-1.c270d4f cl-serapeum@0.0.0-13.71f35c9 cl-simple-date-time@0.1.0-1.d6992af cl-symbol-munger@0.0.1-2.e96558e cl-trivia@0.1-0.8b406c3
Channel: guix
Location: gnu/packages/lisp-xyz.scm (gnu packages lisp-xyz)
Home page: https://github.com/phantomics/april
Licenses: ASL 2.0
Build system: asdf/source
Synopsis: Array Programming Re-Imagined in Lisp
Description:

April compiles a subset of the APL programming language into Common Lisp. Leveraging Lisp's powerful macros and numeric processing faculties, it brings APL's expressive potential to bear for Lisp developers. Replace hundreds of lines of number-crunching code with a single line of APL.

ecl-nfiles 1.1.4
Dependencies: ecl-iolib@0.8.4-0.010b7a6 gnupg@2.5.21 ecl-alexandria@1.4-0.009b7e5 ecl-nclasses@0.6.1 ecl-quri@0.7.0-0.03ecaf3 ecl-serapeum@0.0.0-13.71f35c9 ecl-trivial-garbage@0.21-0.3474f64 ecl-trivial-package-local-nicknames@0.2 ecl-trivial-types@0.0.1
Channel: guix
Location: gnu/packages/lisp-xyz.scm (gnu packages lisp-xyz)
Home page: https://github.com/atlas-engineer/nfiles
Licenses: Modified BSD
Build system: asdf/ecl
Synopsis: Manage file persistence and loading in Common Lisp
Description:

NFiles is a Common Lisp library to help manage file persistence and loading, in particular user-centric files like configuration files. It boasts the following features:

  • Dynamic and customizable path expansion.

  • Extensible serialization and deserialization.

  • Cached reads and writes. When a file object expands to the same path as another one, a read or write on it won’t do anything in case there was no change since last write.

  • (Experimental!) On-the-fly PGP encryption.

  • Profile support.

  • On read error, existing files are backed up.

  • On write error, no file is written to disk, the existing file is preserved.

clasp-iterate 1.5.3
Channel: guix
Location: gnu/packages/lisp-xyz.scm (gnu packages lisp-xyz)
Home page: https://common-lisp.net/project/iterate/
Licenses: Expat
Build system: asdf/clasp
Synopsis: Iteration construct for Common Lisp
Description:

iterate is an iteration construct for Common Lisp. It is similar to the CL:LOOP macro, with these distinguishing marks:

  • it is extensible,

  • it helps editors like Emacs indent iterate forms by having a more lisp-like syntax, and

  • it isn't part of the ANSI standard for Common Lisp.

sbcl-depot 1.0.0-2.6b46c7d
Dependencies: sbcl-atomics@1.0.0-3.5b36bf2 sbcl-babel@0.5.0-3.627d6a6 sbcl-documentation-utils@1.2.0-1.cd5b506 sbcl-trivial-features@1.0 sbcl-trivial-gray-streams@2.0-1.2b3823e sbcl-zippy@1.1.0-1.ed9bca5
Channel: guix
Location: gnu/packages/lisp-xyz.scm (gnu packages lisp-xyz)
Home page: https://shinmera.com/docs/depot/
Licenses: Zlib
Build system: asdf/sbcl
Synopsis: Protocol for transparent collections of files
Description:

This is a system presenting a protocol for "file systems": things that present a collection of "files," which are things that have several attributes, and a central data payload. Most notably this includes the OS filesystem, but can also be used to address other filesystem-like things like archives, object stores, etc. in the same manner.

ecl-sha3 1.1.2
Channel: guix
Location: gnu/packages/lisp-xyz.scm (gnu packages lisp-xyz)
Home page: https://github.com/pmai/sha3
Licenses: Expat
Build system: asdf/ecl
Synopsis: SHA-3 implementation for Common Lisp
Description:

This library is an implementation of the Secure Hash Algorithm 3 (SHA-3), also known as Keccak. The implementation is constrained to messages with an integral number of octets,i.e. sub-byte length messages are not supported.

Total packages: 74714