_            _    _        _         _
      /\ \         /\ \ /\ \     /\_\      / /\
      \_\ \       /  \ \\ \ \   / / /     / /  \
      /\__ \     / /\ \ \\ \ \_/ / /     / / /\ \__
     / /_ \ \   / / /\ \ \\ \___/ /     / / /\ \___\
    / / /\ \ \ / / /  \ \_\\ \ \_/      \ \ \ \/___/
   / / /  \/_// / /   / / / \ \ \        \ \ \
  / / /      / / /   / / /   \ \ \   _    \ \ \
 / / /      / / /___/ / /     \ \ \ /_/\__/ / /
/_/ /      / / /____\/ /       \ \_\\ \/___/ /
\_\/       \/_________/         \/_/ \_____\/

Enter the query into the form above. You can look for specific version of a package by using @ symbol like this: gcc@10.

API method:

GET /api/packages?search=hello&page=1&limit=20

where search is your query, page is a page number and limit is a number of items on a single page. Pagination information (such as a number of pages and etc) is returned in response headers.

If you'd like to join our channel search send a patch to ~whereiseveryone/toys@lists.sr.ht adding your channel as an entry in channels.scm.


go-github-com-cevatbarisyilmaz-ara 0.0.5
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://github.com/cevatbarisyilmaz/ara
Licenses: Expat
Build system: go
Synopsis: Dialer with customizable resolver
Description:

Package ara provides a dialer with customizable resolver. It can be used with http.Client and http.Transport to alter host lookups.

go-github-com-labstack-echo-v5 5.1.1
Propagated dependencies: go-golang-org-x-net@0.53.0 go-golang-org-x-time@0.14.0
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://echo.labstack.com/
Licenses: Expat
Build system: go
Synopsis: High performance, minimalist Go web framework
Description:

Package echo implements a high performance, minimalist Go web framework. Features:

  • optimized HTTP router which smartly prioritize routes

  • build robust and scalable RESTful APIs

  • group APIs

  • extensible middleware framework

  • define middleware at root, group or route level

  • data binding for JSON, XML and form payload

  • handy functions to send variety of HTTP responses

  • centralized HTTP error handling

  • template rendering with any template engine

  • define your format for the logger

  • highly customizable

  • automatic TLS via Let’s Encrypt

  • HTTP/2 support

go-github-com-aws-aws-sdk-go-v2-feature-ec2-imds 1.18.17
Propagated dependencies: go-github-com-aws-aws-sdk-go-v2@1.41.7 go-github-com-aws-smithy-go@1.24.0
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://github.com/aws/aws-sdk-go-v2
Licenses: ASL 2.0
Build system: go
Synopsis: AWS SDK for Go v2 - EC2 IMDS module
Description:

Package imds provides the API client for interacting with the Amazon EC2 Instance Metadata Service.

go-github-com-sacloud-go-http 0.1.9
Propagated dependencies: go-github-com-hashicorp-go-retryablehttp@0.7.8 go-go-uber-org-ratelimit@0.3.1
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://github.com/sacloud/go-http
Licenses: ASL 2.0
Build system: go
Synopsis: HTTP client library for SAKURA cloud in Go
Description:

This package provides a HTTP client functionality that can be used across various Sakura Cloud APIs (IaaS, ObjectStorage, PHY, etc.).

go-gopkg-in-telebot-v3 3.3.8
Propagated dependencies: go-github-com-goccy-go-yaml@1.18.0 go-github-com-spf13-viper@1.8.1
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://github.com/go-telebot/telebot
Licenses: Expat
Build system: go
Synopsis: Telegram bot framework in Golang
Description:

Telebot is a bot framework for Telegram Bot API. This package provides the best of its kind API for command routing, inline query requests and keyboards, as well as callbacks.

go-google-golang-org-genproto-googleapis-api 0.0.0-20250519155744-55703ea1f237
Propagated dependencies: go-google-golang-org-genproto-googleapis-rpc@0.0.0-1.49b9836 go-google-golang-org-grpc@1.69.2 go-google-golang-org-protobuf@1.36.11
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://github.com/googleapis/go-genproto
Licenses: ASL 2.0
Build system: go
Synopsis: API implementation of Google Cloud Platform in Golang
Description:

This package provides an API to interact with GCP.

menshen 1.8.1
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://0xacab.org/leap/menshen
Licenses: GPL 3
Build system: go
Synopsis: Gateway & bridge distribution service for LEAP VPN
Description:

menshen is a resource distributor for LEAP VPN. Here, resource means information for accessing either gateways, bridges, or a combination of the two. This information includes not only endpoint discovery but also credentials (although the credential distribution is not fully integrated at this point). In chinese folk religions, menshen are guardians of doors and gates.

go-go-opentelemetry-io-otel-metric 1.42.0
Propagated dependencies: go-github-com-cespare-xxhash-v2@2.3.0 go-github-com-go-logr-logr@1.4.3 go-github-com-go-logr-stdr@1.2.2 go-go-opentelemetry-io-auto-sdk@1.1.0
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://opentelemetry.io/
Licenses: ASL 2.0
Build system: go
Synopsis: OpenTelemetry Metric API
Description:

Package metric provides an implementation of the metric part of the OpenTelemetry API.

go-go-opentelemetry-io-contrib-instrumentation-net-http-httptrace-otelhttptrace 0.62.0
Propagated dependencies: go-go-opentelemetry-io-contrib-instrumentation-net-http-otelhttp@0.62.0 go-go-opentelemetry-io-otel@1.42.0 go-go-opentelemetry-io-otel-metric@1.42.0 go-go-opentelemetry-io-otel-sdk@1.33.0 go-go-opentelemetry-io-otel-sdk-metric@1.33.0 go-go-opentelemetry-io-otel-trace@1.42.0
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://go.opentelemetry.io/contrib
Licenses: ASL 2.0
Build system: go
Synopsis: OTLP instrumentation library for @code{net/http/httptrace}
Description:

Package otelhttptrace provides instrumentation for the /net/http/httptrace package.

go-github-com-aws-aws-sdk-go-v2-service-sso 1.30.9
Propagated dependencies: go-github-com-aws-smithy-go@1.24.0
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://github.com/aws/aws-sdk-go-v2
Licenses: ASL 2.0
Build system: go
Synopsis: AWS SDK for Go v2 - SSO service module
Description:

Package sso provides the API client, operations, and parameter types for AWS Single Sign-On.

go-github-com-santhosh-tekuri-jsonschema-v6 6.0.2
Propagated dependencies: go-github-com-dlclark-regexp2@1.11.5 go-golang-org-x-text@0.38.0
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://github.com/santhosh-tekuri/jsonschema
Licenses: ASL 2.0
Build system: go
Synopsis: JSONSchema validation using Golang
Description:

Package jsonschema provides json-schema compilation and validation.

go-codeberg-org-tslocum-gmitohtml 1.0.6
Dependencies: xdg-utils@1.2.1
Propagated dependencies: go-gopkg-in-yaml-v2@2.4.0
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://codeberg.org/tslocum/gmitohtml
Licenses: Expat
Build system: go
Synopsis: Gemini to HTML conversion tool and daemon
Description:

This package provides a Gemini to HTML conversion tool and daemon.

go-github-com-jsimonetti-rtnetlink-v2 2.0.2
Propagated dependencies: go-github-com-mdlayher-netlink@1.7.2 go-golang-org-x-sys@0.46.0
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://github.com/jsimonetti/rtnetlink
Licenses: Expat
Build system: go
Synopsis: Low-level access to the Linux rtnetlink API
Description:

This package allows the kernel's routing tables to be read and altered. Network routes, IP addresses, Link parameters, Neighbor setups,Queueing disciplines, Traffic classes and Packet classifiers may all be controlled. It is based on netlink messages.

go-0xacab-org-leap-obfsvpn 1.3.0
Propagated dependencies: go-github-com-labstack-echo-v4@4.15.2 go-github-com-quic-go-quic-go@0.52.0 go-github-com-sirupsen-logrus@1.9.3 go-github-com-xtaci-kcp-go-v5@5.6.18 go-gitlab-com-yawning-obfs4-git@0.0.0-20231012084234-c3e2d44b1033 go-gitlab-torproject-org-tpo-anti-censorship-pluggable-transports-goptlib@1.6.0
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://0xacab.org/leap/obfsvpn
Licenses: FreeBSD
Build system: go
Synopsis: OBFS4 client and server proxies
Description:

The @codeobfsvpn module contains a Go package that provides server and client components to use variants of the obfs4 obfuscation protocol. It is intended to be used as a drop-in Pluggable Transport for OpenVPN connections (although it can be used for other, more generic purposes).

go-github-com-emersion-go-mbox 1.0.3
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://github.com/emersion/go-mbox
Licenses: Expat
Build system: go
Synopsis: Go library for handling @code{mbox} files
Description:

This package provides a library for parsing and formatting mbox files.

go-github-com-evanphx-json-patch-v5 5.9.11
Propagated dependencies: go-github-com-jessevdk-go-flags@1.6.1 go-github-com-pkg-errors@0.9.1
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://github.com/evanphx/json-patch
Licenses: Modified BSD
Build system: go
Synopsis: Apply and create JSON (RFC6902 and RFC7386) patches for Golang
Description:

jsonpatch is a library which provides functionality for both applying RFC6902 JSON patches against documents, as well as for calculating & applying RFC7396 JSON merge patches.

go-github-com-mdlayher-netlink 1.7.2
Propagated dependencies: go-github-com-google-go-cmp@0.7.0 go-github-com-josharian-native@1.1.0 go-github-com-mdlayher-socket@0.5.1 go-golang-org-x-net@0.53.0 go-golang-org-x-sys@0.46.0
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://github.com/mdlayher/netlink
Licenses: Expat
Build system: go
Synopsis: Low-level access to Linux netlink sockets
Description:

This package provides a low-level access to Linux netlink sockets (AF_NETLINK).

go-github-com-pascaldekloe-goe 0.1.1
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://github.com/pascaldekloe/goe
Licenses: CC0
Build system: go
Synopsis: Enterprise tooling for Golang
Description:

Common enterprise features for the Go programming language.

go-github-com-fasthttp-websocket 1.5.12
Propagated dependencies: go-github-com-klauspost-compress@1.18.0 go-github-com-savsgio-gotils@0.0.0-20240704082632-aef3928b8a38 go-github-com-valyala-fasthttp@1.71.0 go-golang-org-x-net@0.53.0
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://github.com/fasthttp/websocket
Licenses: FreeBSD
Build system: go
Synopsis: WebSocket implementation for fasthttp
Description:

Package websocket implements the WebSocket protocol defined in RFC 6455 for fasthttp.

go-github-com-ooni-oohttp 0.8.1
Propagated dependencies: go-golang-org-x-net@0.53.0
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://github.com/ooni/oohttp
Licenses: Modified BSD
Build system: go
Synopsis: Modified fork of Go stdlib's @code{net/http}
Description:

Package http is a fork of stdlib's net/http that provides HTTP client and server implementations that are compatible with alternative TLS libraries such as github.com/refraction-networking/utls.

go-github-com-colinmarc-hdfs-v2 2.4.0
Propagated dependencies: go-github-com-jcmturner-gokrb5-v8@8.4.4 go-github-com-pborman-getopt@1.0.0 go-google-golang-org-protobuf@1.36.11
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://github.com/colinmarc/hdfs
Licenses: Expat
Build system: go
Synopsis: HDFS for Go
Description:

This package provides a native, idiomatic interface to HDFS. Where possible, it mimics the functionality and signatures of the standard `os` package.

protoc-gen-go-grpc 1.5.1
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://google.golang.org/grpc
Licenses: ASL 2.0
Build system: go
Synopsis: Generate Go bindings of gRPC's services in protobuf definition files
Description:

This package provides a plugin for the Google protocol buffer compiler to generate Go code.

go-github-com-go-fed-httpsig 1.1.0
Propagated dependencies: go-golang-org-x-crypto@0.53.0
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://github.com/go-fed/httpsig
Licenses: Modified BSD
Build system: go
Synopsis: Golang implementation of the HTTP Signatures RFC draft
Description:

This package implements HTTP request and response signing and verification. Supports the major MAC and asymmetric key signature algorithms. It has several safety restrictions: One, none of the widely known non-cryptographically safe algorithms are permitted; Two, the RSA SHA256 algorithms must be available in the binary (and it should, barring export restrictions); Finally, the library assumes either the Authorizationn or Signature headers are to be set (but not both).

go-github-com-emersion-go-message 0.18.1
Propagated dependencies: go-golang-org-x-text@0.38.0
Channel: guix
Location: gnu/packages/golang-web.scm (gnu packages golang-web)
Home page: https://github.com/emersion/go-message
Licenses: Expat
Build system: go
Synopsis: Internet messages and MIME for Go
Description:

The message package implements the Internet Message Format and Multipurpose Internet Mail Extensions in Go.

Total packages: 74733